Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

Installing active perl 5

Hi guys I am new to Perl.

I use windows XP

I am having problem with installing Perl 5 or PDK 8

I have down loaded them as I try to install, I get the following message.

new window with ICONS: Perl, PPM, Documentation, Example.

And nothing happens after that.

If I right click on these on PDK 8, I get choices , install, modify, un - install, or open with, etc. I

Click on open with: internet explorer ; It opens and closes

If I try to open with window installer nothing happens.

Can some one help

Perl for IA64 Windows

I currently produce applications for x86 and x64 Windows servers using PDK for 32 bit and 64 servers, but now have the requirement to support IA64 Itanium Windows servers. On an IA64 W2K3 development server the x64 apps will not run and error with :-

The image file xxx.exe is valid, but is for a machine type other than the current machine.

The 32 bit compiled apps however run fine in compatability mode.

My question is, is it possible to compile native IA64 Perl apps for Windows with ActivePerl and PDK? If yes please can someone give me some pointers.

Thanks in advance

Installation of ActivePerl on Vista

I was trying to install ActivePerl-5.8.8.819-MSWin32-x86-267479 on Vista, but i was unable to install.

machines config
================
Manufacturer: HCL
Processor: Genuine Intel(R) T2130@1.86GHZ
Memory: 895MB
System Type: 32 bit

Firewall is turned off

Error Message:
==============
Installing ActivePerl...

Copying files...
3102 File(s) copied
Finished copying files...
Relocating...done (70 files relocated)
Access is denied.
Error occurred while processing: .pl.
Could not create .pl file type association

silent install with TARGETDIR creates Perl subdir

Hello

I have an issue when installing ActivePerl silently.
This issue is referenced : http://bugs.activestate.com/show_bug.cgi?id=28192

"
The Installation works fine except for one problem, despite of specifing the TARGET directory where the product should be installed the MSI file creates a subfolder "perl" under the specified directory. How can we tell the MSI file not to create this subfolder?

start /wait msiexec /qb /l* ap510.log /i %AP_MSI% ADDLOCAL="PERL_FEATURE,PPM" PERL_PATH=No PERL_EXT=No TARGETDIR=d:\APPS\ap510
"

Do you know how to fix this bug ?

Regards
Pascal

Running ActivePerl on Windows XPe

I have a some code that runs in Internet Explorer 6 on Windows 2000. It uses both JavaScript and PerlScript. I've been trying to move it to Windows XP Embedded with no success.

I created a XPe target image with just device drivers, minlogon, DirectX 9.0c and Internet Explorer 6. I put it on the machine and installed ActivePerl. Then I tried to run my program. It failed with "Internal Error" and said it was at line 1, Char 0.

Windows Server 2008

Could you tell me if the latest version of ActivePerl is supported on Windows server 2008?

Need Answers

Ok here's the deal. I have active perl installed on Windows Vista. Everything works fine. No problems what so ever. The issue I am having involves XP. I have a friend online whom was interested in perl, and they are on XP. I had them install active perl, and install it correctly. I guided them through their first application set up, (which was actually an irc chat bot).

How do I run perl scripts with Active Perl installed?

Hi, just recently installed Active Perl on my Windows Vista laptop so I can run Perl programs here. Have been generally using Perl in office only, UNIX machines.

1) How can I run Perl programs? Where should I put it?
2) What is the common Perl editor you guys are using?

Thanks!

Install an older version

I'm trying to install an older version of perl but the system complains that there are newer versions already installed and it doesn't appear to do anything after that. I looked around for a 5.10 directory of some sort but couldn't find anything. I'm trying to install 5.8. How can I tell if 5.10 is installed and how can I remove it? If it has been removed (in it's entirity or partially) how can I tell and what do I have to do to fully remove it? Any help would be grealty appreciated.

ActivePerl on Linux

I've downloaded version 5.10 (rpm download) onto my Linux machine. I've put it onto a directory called /opt/pdk/ and in a shell I navigated to this directory and ran rpm -i ActivePerl......rpm. It never gave any feedback but there is now a directory underneath /opt/ called ActivePerl-5.10. If I do a perl -v at the shell prompt it still gives me version 5.6. First off how can I have the system recognize perl 5.10 as being the active version of perl (if I wanted or needed to)?