Installation Support for ActivePerl

Installation Problems, Installer content, and FAQs for ActivePerl

ActivePerl Migration Win 2003 Server to Win 2008 Server

Hello,

I have got a couple of medium-sized (1000+ lines of code) of Perl programs (64 bits) running on Windows Server 2003, the perl version is:

C:\>perl -v
This is perl, v5.10.1 built for MSWin32-x64-multi-thread
(with 2 registered patches, see perl -V for more detail)
Binary build 1007 [291969] provided by ActiveState http://www.ActiveState.com
Built Jan 27 2010 14:12:21

I am using ADODB to connect to MSAccess databases, I read ActiveDirectory entries and I use StorageCentral to setup Storage quotas for 1000+ directories.

Upgrading from 5.8.7 build 815

I need to upgrade my ActivePerl version 5.8.7 build 815 to the latest version. I dloaded the ActivePerl-5.12.1.1201-MSWin32-x86-292674.msi file but when I run it the installer tells me I have an incompatible version installed in the c:\Perl folder. Do I have to uninstall the old version first or is/are there other version(s) I must upgrade to first before I can use the new install.

Thanks in advance…

How to change the perl installed path

Hi,
I installed perl 5.10 under c:\perl_510 to test it and after having tested it and installed all missing modules would like to change the directory to c:\perl i.e the standard path. Its there any possibility of doing this? I think just renaming the directory and setting the env variable 'path' ist not sufficient as all the installed packaged have this installed directory in their .packlist files and also doing a search of the string c:\perl_510 yields a lot of files with this string hard-coded in them.
Any help is very much appreciated

thanks
osman

Perl 5.12 interpreter abort, only if run from Explorer

I have a specific script (not that complicated, but a bit inappropriate to post in its entirety here) that aborts under all the following conditions:

  1. The line
    use 5.12.0;

    appears near the top of the script;

  2. the script is invoked by double clicking the file in Windows Explorer; and
  3. the script is located on a network drive.

The error message box says: 'Perl Command Interpreter has encountered a problem and needs to close'.

If any of these conditions are changed, the script runs fine. For instance,

Installing manually only ActiveScripting?

Hello!

AP free edition.

Is there a possibility to register only components required for ActiveScripting support, without running the installer?
I mean just unpacking perl archive and running some commmands by hand.

TIA

Cannot Install ActivePerl 5.10.1 Build 100[457]

When I try to install ActivePerl 5.10.1 Builds 1004, 1005, or 1007, I get the following message box:

Installer Information
The system cannot open the device or file specified.
[Retry] [Cancel]

If I click [Retry], the same message box appears. If I click [Cancel], I get:

Installer Information
Internal Error 2755. 110,
D:\Downloads\Perl\ActivePer-5.10.1.1007-MSWIN32-x86-291969.msi
[OK]

Clicking [OK] displays the setup wizard with a message that says that the "Setup Wizard ended prematurely"

I'm running 32-bit Windows 7 Enterprise.

How to do in-place upgrade of Perl

I was wondering if it was possible to upgrade to the latest version of perl without having to download the installer again for Perl 5.12. I already have 5.10.1. What I am thinking of is a update like it's done for modules via PPM.

.pl file associations for multiple users in Windows 7

I recently signed onto a Windows 7 computer and installed the 32 bit ActionPerl msi on our domain. Now when I sign in and goto the commnad prompt, I can run .pl files without the full path and it knows to associate the .pl file with the perl executable. However when one of our other users logs in, he is unable to run the perl scripts without using the full path and the preceding perl call. It seems that the file associations for pl worked fine for myself, but I need these to be associated for a few other users. I wanted to know how I can go about doing this.

Active State Perl 5.8 install directory on W2K8R2 x64

Hello everyone,

I have to run an automated installation of Perl 64 bit on a W2K8R2x64 server.
In order to keep compatibility with old administration scripts, we have to install Perl in folder "D:\Perl", so i try the following command line:

D:\> ActivePerl-5.8.9.827-MSWin32-x64-291969.msi /q /passive TARGETDIR="D:\Perl\" PERL_PATH="Yes"

--> installation works perfectly except that files are copied in "D:\Perl\Perl64", instead of "D:\Perl".

But when I run installation from the UI, i can change the installation directory to D:\Perl, and files are really copied in "D:\Perl"....

Where can I get ActivePerl 5.8.8 for Solaris

Hi
I have a product on Solaris SPARC certified with ActivePerl 5.8.8. I know the product QA was done with build 820. This version is no longer available on the downloads or archives.
Where can I get it?
Thanks in advance.