Upgrading from 5.8.7 build 815

Posted by blackdogsociety on 2010-08-06 09:42

I need to upgrade my ActivePerl version 5.8.7 build 815 to the latest version. I dloaded the ActivePerl-5.12.1.1201-MSWin32-x86-292674.msi file but when I run it the installer tells me I have an incompatible version installed in the c:\Perl folder. Do I have to uninstall the old version first or is/are there other version(s) I must upgrade to first before I can use the new install.

Thanks in advance…

grahams
ActiveState Staff
Wed, 2010-09-01 10:39

The compiled portions of 5.12 are binary incompatible with compiled 5.8. You need to use a new path or do a clean re-install.

http://docs.activestate.com/activeperl/5.12/install.html#upgrade