Upgrade from 5.10.0 to 5.12.2

Posted by kalvaro2 on 2010-10-14 00:12
Forums: PPM | OS: Windows XP Pro

I'm getting lots of "404 Not Found" error messages when installing new Perl modules so I thought I should upgrade to the latest ActivePerl version. I'm following the instructions found at:

http://community.activestate.com/forum/upgrading-587-build-815
http://docs.activestate.com/activeperl/5.12/install.html#upgrade

I'm currently using ActivePerl 5.10.0.1003, I'm trying to upgrade to 5.12.2.1202 and I'm using Windows XP Professional. This is what I get:

C:\>ppm install PPM-Profile
Downloading ActiveState Package Repository packlist...done
Updating ActiveState Package Repository database...done
Downloading uwinnipeg packlist...not modified
Downloading trouchelle packlist...not modified
Downloading PPM-Profile-1.4...done
Unpacking PPM-Profile-1.4...done
Generating HTML for PPM-Profile-1.4...done
Updating files in site area...done
4 files installed

C:\>
C:\>ppmprofile save C:\profile.xml
C:\Perl\site\bin/ppmprofile.bat save is not supported for PPM4 yet at C:\Perl\site\bin/ppmprofile.bat line 94

How should I proceed?

P.D. Are you planning an upgrade feature for next releases?