teacup proxy settings for user and password?

Posted by rich on 2009-04-06 09:58
Forums: TEA discussions | OS: All / Any

Does anyone know of a way to add a user name and password to the http-proxy settings for teacup?

When I try to use teacup to update my repository I get the following error message from my company proxy server:
Access Denied (authentication_failed)
Your credentials could not be authenticated: "Credentials required.". You will not be permitted access until your credentials can be verified.

I tried adding the proxy setting using the -–http-proxy parameter in the teacup update command and I also tried setting the proxy using the teacup proxy command and get the same results both ways.

As a work-around I borrowed a lap-top and updated my repositories from home but I would really rather be able to do this from work.

Internet Explorer and my other internet applications work just fine with the proxy. I assume they must have some way to authenticate with the proxy server.

Any ideas?

patthoyts | Thu, 2009-04-09 14:59

You can set the following environment variables:

 set http_proxy=http://proxyhost:80/
 set http_proxy_user=NTDOMAIN\username
 set http_proxy_pass=yourpassword

Indeed, Internet Explorer has special magic to pick up the NT login details and pass those to the network proxy. The package used in teacup will attempt to autoconfigure your proxy but cannot provide the authentication details yet. Possibly this will be done in the future as it may be done by providing an SSPI extension.

rich | Thu, 2009-04-09 15:26

I tried your suggestion and it works! Thanks for taking the time to respond!

matta | Thu, 2010-01-21 13:03

have tried the suggestion of setting above variables at the CMD prompt on Windows, and then entering tclsh85 .
No luck. :(

I still end up with authentication rubbish sprayed when I try to use teacup.

edwinbmiller | Tue, 2012-03-13 05:18

set 3 environment variables
set http_proxy=http://proxyhost:80/
set http_proxy_user=NTDOMAIN\username
set http_proxy_pass=yourpassword

then tried
teacup install -v Expect

but still get auth errors, has anyone been successful with this version of tcl?