Syntax highlighting

Posted by lucazav on 2009-09-29 03:31

I noticed Komodo can't recognize the Smarty componentized template syntax in the first row of a .tpl file, like this one:
{load_presentation_object filename="submitted_order" assign="obj"}
(you can see it in the attachment)
The error info i get is:
Info: < head > previously mentioned
Am I missing anything or is it a known bug?

Thank you very much.
Luca

AttachmentSize
SmartyHighlighting.png4.42 KB

ericp
ActiveState Staff
Tue, 2009-09-29 17:25

The first is a known bug -- we're using the HTML syntax checker for
Smarty files. Specifically, we're using HTML Tidy, and it doesn't
know about Smarty syntax.

The second bug should have been fixed in version 5.2.1, but it's
showing up here. Komodo should be using HTML-specific string
coloring for the class attribute in the div tag, and Smarty-specific
string color for the strings in the load_presentation_object_filename
line, but I see that it's using the Smarty style in both cases.

Entered in http://bugs.activestate.com/show_bug.cgi?id=84822

- Eric

lucazav | Mon, 2009-10-05 12:31

My current version is 5.3.0, build 4114 and it seems to have those bugs.

Thank you,
Luca

ericp
ActiveState Staff
Mon, 2009-10-05 12:59

We haven't shipped Smarty font colors for the HTML-specific parts, but they're still lingering in your schemes. The best way to remove them is to bring up the
Smarty language in [Preferences|Fonts and Colors|Lang-Specific=Smarty], and
press the Reset button for the affected Element Types. Unfortunately there's
no [Reset All] button, but probably the only ones you'll need to reset are
"tags", "attribute names", and "attribute values".

lucazav | Mon, 2009-10-05 13:08

Thank you for your reply.