Spreadsheet-WriteExcel installed but prog in komodo ide can't locate it

Posted by whmcqueary on 2009-05-28 11:39
Forums: PPM | OS: OS X 10.5 (Leopard)

I'm new to working with PERL and just installed ActivePerl so sorry if this is a quick fix. =) I did have this program running on a debian box the other day. I have activeperl 5.10.0.1005 installed and have installed Spreadsheet-WriteExcel through PPM but when komodo hits this:

use Spreadsheet::WriteExcel;

This is what I'm getting:

Can't locate Spreadsheet/WriteExcel.pm in @INC (@INC contains: /Applications/Komodo IDE.app/Contents/SharedSupport/dbgp/perllib /Library/Perl/Updates/5.8.8 /System/Library/Perl/5.8.8/darwin-thread-multi-2level /System/Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-thread-multi-2level /Library/Perl/5.8.8 /Library/Perl /Network/Library/Perl/5.8.8/darwin-thread-multi-2level /Network/Library/Perl/5.8.8 /Network/Library/Perl /System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/5.8.1 .) at /Users/whmcqueary/Desktop/PERL/excel_test_2.pl line 6.
BEGIN failed--compilation aborted at /Users/whmcqueary/Desktop/PERL/excel_test_2.pl line 6.

I even downgraded to 5.8 thinking it might make a difference but it didn't seem to, I get the same error. I'm not seeing my PPM @INC path listed under prefs (/Users/whmcqueary/Library/ActivePerl-5.10/lib) in the error. Any help? Thanks.

ericp | Fri, 2009-05-29 14:41

I tried it on a Mac, and it works fine.

The interesting thing about this Mac is that there are at
least three different perl installations on it -- I needed
to make sure that Komodo was using the same Perl that
I had installed the module on. See [Preferences|
Languages|Perl].

Regards,
Eric Promislow