Problem installing UDP Package

Posted by terryoneal on 2010-10-08 07:18
Forums: TEA discussions | OS: Windows 7

I just upgraded my machine from WinXP to Win7. I then installed ActvieTCL 8.5.9 and attempted to use teacup to install the udp package. However, I get the following error:

Retrieving package udp 1.0.9 win32-x86_64 ...@ http://teapot-be.activestate.com
... Error:

        This operation needs a business edition license installed to
        succeed. Please visit
        http://www.activestate.com/business-edition to learn more about
        the ActiveTcl Business Edition offering.

        Unable to install the full list. Aborting.

This worked fine with my previous installation of 8.5.2 on WinXP - Did something change or is this a bug?

Thanks,
Terry

jeffh
ActiveState Staff
Fri, 2010-10-08 13:12

Hi Terry,

As the message indicated, you need a BE license to access the 64-bit Windows teapot repository. It looks like the one change is that you moved to using 64-bit ActiveTcl.

If you want to continue with the free and unsupported CE option, just download the 32-bit Windows ActiveTcl. This will run fine on a 64-bit Windows machine and the teapot repository is open to CE users.

Jeff

terryoneal | Fri, 2010-10-08 13:24

Thanks Jeff, that worked.. I didn't realize there were limitations when moving to 64-bit.. I just figured I'd download the one that matched my machine..