PPM showing old module version

Posted by Mike Gajewski on 2008-11-13 07:10
Forums: PPM | OS: Windows XP Pro

After upgrading from 5.8.2.808 to the recently released 5.8.8.824, my Perl scripts using the Graph.pm module stopped working. The reason is that the 5.8.8 PPM installs a very old version (0.20105) of Graph.pm instead of the new version (0.84).

The ActiveState CPAN PPM Repository Package index shows version 0.84 is available for MS Windows, but that version does not display in PPM. I tried installing the PPMX file, but PPM aborts with "ppm install failed: 501 Protocol scheme 'c' is not supported".

How can I get PPM to install version 0.84?

grahams
ActiveState Staff
Wed, 2009-02-18 10:47

This looks like a bug in the PPM build system. The newer versions are building fine but are not getting added to the list. We're looking into it.