Not able ito install IO-TTy 1.07 on windows XP prof

Posted by kotesh_j on 2009-02-24 01:47
Forums: PPM | OS: Windows XP Pro

I am not able to install IO-Tty 1.07 in windows xp i am using Active state 5.10.0

i didnot find this IO::Tty module in PPM. can u please tell me where i have to check for config.pm

when i am trying to compile it is showing the following error

Can u please help me

D:\Perl\mods\IO-Tty-1.07>perl Makefile.pl
Set up gcc environment - 3.4.5 (mingw-vista special r3)
Now let's see what we can find out about your system
(logfiles of failing tests are available in the conf/ dir)...

ERROR: cannot run the configured compiler 'gcc'
(see conf/compilerok.log). Suggestions:
1) The complier 'gcc' is not in your PATH. Add it
to the PATH and try again. OR
2) The compiler isn't installed on your system. Install it. OR
3) You only have a different compiler installed (e.g. 'gcc').
Either fix the compiler config in the perl Config.pm
or install a perl that was built with the right compiler
(you could build perl yourself with the available compiler).

Note: this is a system-administration issue, please ask your local
admin for help. Thank you.

grahams
ActiveState Staff
Wed, 2009-03-25 08:19

http://cpansearch.perl.org/src/RGIERSIG/IO-Tty-1.08/README

You need to rewrite your script to use it on Windows, or run it under a Linux emulator like Cygwin (which introduces a new set of things you'll need to know about).