Net::SSLeay

Posted by loubarone on 2010-11-19 09:28
Forums: PPM | OS: Windows x64

Where can I find Net::SSLeay for Windows 7 x64 - ActivePerl 5.10 - am trying to send email through gmail - succeeds on Linux but can't find this module for Windows 7 - don't know how to compile it for myself - any ideas? - stumped

chorny | Sun, 2010-11-21 15:49

Did you try ppm install Net-SSLeay with additional repositories turned on?

If it does not work, you can try to extract it from Strawberry Perl 5.10.

loubarone | Mon, 2010-11-22 05:59

I have made multple attempts from each repository.

Here's the message I get ...

Can't locate loadable object for module Net::SSLeay in @INC (@INC contains: ... .) at C:/Perl64/site/lib/IO/Socket/SSL.pm line 18
Compilation failed in require at C:/Perl64/site/lib/IO/Socket/SSL.pm line 18.
BEGIN failed--compilation aborted at C:/Perl64/site/lib/IO/Socket/SSL.pm line 18.
Compilation failed in require at C:/Perl64/site/lib/Net/SMTP/SSL.pm line 8.
BEGIN failed--compilation aborted at C:/Perl64/site/lib/Net/SMTP/SSL.pm line 8.
Compilation failed in require at SendEmail.pm line 3.
BEGIN failed--compilation aborted at SendEmail.pm line 3.

The .PMs and subdirectories for SSLeay ARE THERE, but the .dll IS NOT. File/directory permissions are all OK. So I suspect that there is no x64 compile of it. I found a SSLeay32.dll but it fails (not the correct file). I've tried to find SSLeay.dll, and tried to compile it myself but I'm getting over my head. I may take another look at CPAN to see if they have a solution somehow ...

Before changing PERL code, or going to Strawberry, I'd really like to fix this SSLeay problem if I can. So all help/suggestions are welcome.