Net::Ping 2.35 installed but not visible in PPM

Posted by jsims_spss on 2008-11-15 00:55
Forums: PPM | OS: Windows XP Pro

Hi All,
After installing ActivePerl-5.10.0.1004-MSWin32-x86-287188.msi, Net::Ping 2.35 is installed on my system but not visible in PPM 4.01. I think it is a problem with the module not being in the repository because an older version of PPM is also no longer showing this module. I know it is installed because the C:\Perl\lib\Net\ping.pm exists.

I tried adding one of the other repositories but it still doesn't show up as being installed.

Any ideas as to how I can make this visible in PPM? I would prefer to upgrade the package rather than reinstall Active Perl on each machine.

Thanks for your help.
-Jeff

grahams
ActiveState Staff
Tue, 2008-11-18 17:06

Anything in C:\Perl\lib is a built-in module and can't be updated with PPM. This is a limitation of the current version of PPM. Modules added by ActiveState will be visible in PPM, but will update to C:\Perl\site\lib. If the module is not visible, it's part of core Perl 5.10.0.