net-ssh-perl won't install: no crypt::idea?!?

Posted by furry_marmot on 2009-03-15 23:16
Forums: PPM | OS: Windows XP Pro

I think this is a PPM question. Correct me if I should post elsewhere.

I'm using Perl 5.10 and WinXP Pro. I have a site that uses SFTP, from which I regularly download log files. I've been using Net::SFTP, which uses Net::SSH::PERL, which uses Crypt::IDEA. I've used these in a script for months now without problem.

I recently had to reinstall Perl (among lots of other things). When I went to run my script, I got a message that said, "Can't locate Net/SFTP.pm in @INC...etc." Fine, so I ran ppm-shell at the command line (MUCH faster than the GUI), searched for Net::SFTP, and tried to install it. I got the following message:

install failed: Can't find any package that provides Crypt-IDEA for Net-SSH-Perl

I've searched all the Perl 5.10 repositories I can find, and I sure can't find Crypt-IDEA either. Nor can I find any recent bugs related to any of the above modules (though I'm not very familiar with where to look).

Can anyone explain what's going on?

I've tried to use LWP with LWP::Protocol::sftp, but I can't figure out how to pass my username and/or password to LWP. HTTP Basic Authentication doesn't seem to work with SFTP. If someone can explain that, at least I can get back to work.

Thanks for any help!

marmot