Need to understand the matching between TCLpro 1.5 and ActiveTCL

Posted by ameurant on 2009-12-07 07:44

Hello,

I am currently looking to understand how TCLpro 1.x (1.4 and above) matches the ActiveTCL 8.x versions for Solaris x86.

From the readme files, it appears that

"TclPro 1.4 bundles Tcl/Tk 8.3.2 and compatible versions of TclX, [incr Tcl], and (for Unix platforms only) Expect. You can download a free copy of TclPro 1.4 for:
• Windows 95, 98, NT 4.0 (Intel), 2000
• Solaris 2.5, 2.6, 7 (SPARC)
• HP-UX 10.20
• Linux (Intel, Red Hat 5.0+, SuSE 6.0+)
• SGI IRIX 6.3+"

I understand that ActiveTCL 8.x now packages and supports TCLpro on Solaris 10 x86, yet what would be the recommended version ?

Many thanks for your help,
Regards,

Arnaud

jeffh
ActiveState Staff
Wed, 2009-12-09 17:06

TclPro was a tools bundle that included a core release. It hasn't been updated in years, and isn't compatible with the latest stable releases of Tcl.

ActiveTcl is a Tcl batteries included distribution. The dev tools have been split off into Tcl Dev Kit and have all been updated and extended. They are also kept current with the latest Tcl releases.

The recommended version of ActiveTcl is 8.5, and the recommended version of Tcl Dev Kit is 5.1.