Looking for DBD::MySQL

Posted by theodorsen on 2009-01-31 07:12
Forums: PPM | OS: Windows Vista

I am running on Vista 64Bit, but this ought to be irrelevant to my problem.
On my old computer i installed v5.8.8 Build 822 and I haf no problems (except my computer being soooooo slow). Now I got a new computer and installed the latest version(10) but sadly enough I can't install DBD-MySQL from ppm. It seems to be unavailable in the repository.
Instead I have tried to install v5.8.8 822 from the old versions page, but here, contrary to my old computer, only the old commandline version of ppm is included and I can't make it to find anything i the repository. It just says that it points to ActiveState and that there are 0 packages available.
All my perl programs are dependent of this package, so I am in real trouble here. I am not sure if I can install the package myself form CPAN and how to do it. Any help will be highly appreciated.

KevinADC | Sat, 2009-01-31 11:46

Open the PPM GUI and there should hopefully be some prelisted repositories you can add to the active repository list. One of them should have DBD::mysql. If you are unsure how to add a repository read the PPM help files. I have these repositories active, DBD::mysql is in one of them:

bribes
trouchelle
uwinnipeg

theodorsen | Sat, 2009-01-31 12:25

The problem is that the PPM GUI is not included in the version I just downloaded. I can only access ppm through the commandline version. On my old computer the GUI version was added to the menu on installation, but here, although it is the same version and build what happens is this: I open the command prompt and enters ppm and get this :
"The PPM graphical interface is not available for this Perl installation."

KevinADC | Sat, 2009-01-31 14:07

Bummer. You can try adding the repositories via the command line.

http://theoryx5.uwinnipeg.ca/ppms/
http://www.bribes.org/perl/ppm
http://trouchelle.com/ppm/

or just try searching each repository. I haven't used the build of activeperl you are trying so I can't be too specific about what you need to do. If all else fails:

ppm help

Worse comes to worse uninstall activeperl and try strawberry perl. That way you have access to all the modules on CPAN.

www.strawberryperl.com

theodorsen | Sat, 2009-01-31 15:32

As I wrote in the first entry, I get this message from ppm on the command 'ppm repo':

id pkgs name
1 0 ActiveState Package Repository

I suppose that this means that there are 0 packages in the repository.
So that does not help me, exept if I have to do something special to get access to the repo.

KevinADC | Sat, 2009-01-31 16:44

And as I said:

ppm help

from there you can read how to add a repository. You may also need to shutdown any firewall that is running before trying to use PPM or add it to the firewalls list of programs that are allowed internet access.

theodorsen | Sat, 2009-01-31 18:56

I have read the ppm help. It says that ActiveState is set as the default repository. So there is a repository, but it seems to be empty.
But perhaps I do not get through to it anyway. On 'ppm search *' I get this answer 'Downloading ActiveState Package Repository packlist...not found / *** no packages found ***', with or without firewall.
I admit that I know little about the commandline version, but I tried to add http://www.cpan.org as a new repository. It was accepted, but also just returns no packages, with or without firewall.
From here I don't find a lot of help in the ppm help.

KevinADC | Sat, 2009-01-31 20:18

I gave you a list of three repositories. DBD::mysql is listed in the unwinnipeg repository. Read the ppm help files and it shows how to request that the module be installed from a specifc ppm repository. Its something like:

install http://theoryx5.uwinnipeg.ca/ppms/ DBD-mysql

theodorsen | Sun, 2009-02-01 06:02

Now I tried to use the commanline on my old computer. There are no problems. I can connect to ActiveState ppm repository, sync it and search. The repo command tells me that there are more than 9500 packages to choose from. I can also add http://theoryx5.... and find the packages.
On my new computer, I made sure that Windows firewall is off, turned F-Secure firewall off and performed the same procedures. On the sync command, for some time it counts up to 100% for both Activestate and uwinnipeg , as if it is downloading the package list, but the repo command still says 0 packages and a search also returns nothing.
To it looks really weird.

KevinADC | Sun, 2009-02-01 10:56

Are you connecting through a proxy? The PPM documentation explains how to set up the proxy environment. You can try using the CPAN shell and building the module. The PPM help files descibe what you need to do to build a module downloaded from CPAN. I have never tried it myself.

theodorsen | Sun, 2009-02-01 12:28

Finally I got it to work. I decided to go back to the lastest version (5.10.0). In the ppm GUI-version I added the Winnipeg repository and succeeded in installing the DBD-MySQL package.
Maybe I can guess the reason for my problems. The only difference between my two computers (except speed) is that the the old one runs on Vista 32Bit and the new one on Vista 64Bit. Probably ppm in v5.8 does only work on 32Bit machines, while v5.10 Works on both.
Anyway, things runs as they should now.
Thanks for your help.

KevinADC | Sun, 2009-02-01 13:16

Glad you got it working.

grahams
ActiveState Staff
Wed, 2009-02-18 09:25

There is only one PPM Repo for Windows 64 bit platforms. It's for Perl 5.10. That's why you don't see any packages for 5.8 on Win 64, no matter how many additional repos you add. Will there ever be one? Maybe. If there's enough interest. It was deemed to be more important to get 64-bit for 5.10 as that's where the future is going.

benhadad | Sun, 2009-03-22 10:04

What? I have the understanding there is no PPM gui for 64bit? So you are using 32bit Perl 5.10 on Vista 64bit machine then?

grahams
ActiveState Staff
Wed, 2009-03-25 08:06

benhadad, you are correct. There are no GUIs in 64-bit. That's because the GUI interfaces depend on several modules in the Win32 space which will not work on 64-bit Windows, and for which there are no Win64 equivalent modules.

theodorsen | Wed, 2009-03-25 09:18

Although it might not be safe and reliable, I actually installed the 32-bit version on my 64-bit machine and had it install the package without any problems from the GUI-version.