Installing old version of module?

Posted by victorhooi on 2009-03-24 17:32
Forums: PPM | OS: Windows XP Pro

heya,

I'm attempting to use the imapsync program on Windows (http://freshmeat.net/projects/imapsync/).

However, according to the INSTALL file (http://www.linux-france.org/prj/imapsync/INSTALL), this requires an older version of the Mail::IMAPClient module, 2.x, rather than 3.x.

Is there a way to install an older version of a package via PPM on Windows?

Victor

grahams
ActiveState Staff
Wed, 2009-03-25 09:54

One of the limitations of the current version of PPM is that only one version of any given module may exist in a repository. Once a module has updated to the latest version, older versions can only be installed from the CPAN source code.

rememberme | Tue, 2018-07-03 01:20

is it still not possible to install older version of modules via PPM?

grahams
ActiveState Staff
Tue, 2018-07-03 09:26

The major version number of PPM has not changed.

The only way to load an older module is to alter the content presented to the PPM client. Manual/Offline downloads is one way to alter the content.
https://community.activestate.com/faq/manual-downloads-ppm-index-page