Installation failure...

Posted by on 2010-01-11 08:05

I am trying to install ActivePython (latest release) under windows 7 64 bit. But the installer fails. I have tried several installation paths (including the proposed one), but it always fails. Any ideas why?

I think the problem is that the setup program never asks elevated privileges. How can I run this .msi file as "Administrator"?

George

sridharr | Mon, 2010-01-11 08:56

1. Fails with what error message?

2. MSI programs seem to always - by design - run as administrator

petasis (not verified) | Mon, 2010-01-11 08:58

The error code is 2755. If it is running as administrator, shouldn't I see a dialog that the program needs elevated privileges to run?
I see no such dialog.

sridharr | Mon, 2010-01-11 10:34

Have you tried googling for this error? If not, I suggest doing so in future. I found a workaround here: http://greystork.com/content.php?id=93 (copy it to local drive before executing) -- let me know if that fixes the issue for you.

-srid

petasis (not verified) | Mon, 2010-01-11 10:57

I am installing this from a local drive. (A raid-1 one). I will try to put it in drive C:...

petasis (not verified) | Mon, 2010-01-11 11:02

Copying it to drive C: and installing from there, work as expected.
This is very strange, but it is either confused by the raid drive, or it is confused if installing on a drive different than the one the setup is.
However, it is the first setup program that shows this strange behaviour.
I have installed everything in my pc from the same location...
(I am not sure however how many setups used this .msi microsoft facility...)

petasis (not verified) | Mon, 2010-01-11 12:48

It seems that the problem was installing from the raid drive. Installing from another disk, worked ok...