@INC Trouble

Posted by emodica on 2010-03-02 15:13
Forums: PPM | OS: Windows XP Pro

I just downloaded the free version of activestate perl and have been trying to get it to work with some national instruments gpib drivers as well as some packages written by Jeff Mock off of cpan. I get everything to build ok but when I try and run an example script it trips over the following line:

use GPIB::hpe3631a;

The error message I get says:
H:\perl\gpib-0.30\examples>ps.pl
Can't locate GPIB/hpe3631a.pm in @INC (@INC contains: C:/Perl/site/lib C:/Perl/l
ib . H:/perl/gpib-0.30/GPIB) at H:\perl\gpib-0.30\examples\ps.pl line 28.
BEGIN failed--compilation aborted at H:\perl\gpib-0.30\examples\ps.pl line 28.

I have both gpib.pm and hp3631a.pm under the H drive path listed above, and the script still can't seem to find this stuff. Any suggestions?

Eric

emodica | Wed, 2010-03-03 14:00

So I figured out that I wasn't running nmake properly. Nmake 1.5 is a self-extracting archive and I mistakenly assumed that running nmake15=nmake. . . not so. But then I ran into a problem using nmake and tried using dmake, which is packaged with the free version of nmake, and that seemed to work. The latest problem is that I get this error when I try and run an example script:

H:\perl\gpib-0.30\examples>ps.pl
Cannot load GPIB::ni for HPE3631A
Can't load 'C:/Perl/site/lib/auto/GPIB/ni/ni.dll' for module GPIB::ni: load_
file:Invalid access to memory location at C:/Perl/lib/DynaLoader.pm line 201.
at (eval 19) line 1
Compilation failed in require at (eval 19) line 1.
BEGIN failed--compilation aborted at (eval 19) line 1.

Is this some kind of permissions issue? Anyone? Anyone? Beuller?

grahams
ActiveState Staff
Tue, 2010-04-06 13:58

Was GPIB/ni/ni.dll built with a compiler that is compatible with ActivePerl? MinGW is usually a good choice for 32-bit Windows. 64-bit ActivePerl is built with the Windows 2003 SDK.