How to add a project specific @INC module-path to Komodo without breaking syntax checking?

Posted by afg on 2009-05-18 21:25
Forums: Komodo support | OS: Windows XP Pro

For a perl porting project I am using ActiveState's Komodo IDE 5.1
The project uses several internal libraries (e.g. xyz.pm). Those modules are stored under different directory trees. (subversion ..)

By adding a

PERL5LIB=(list of path to lib)

under the "environemt" tab of the debu/run dialog, I can show Komodo/Perl how to run the script.

Unfortunately the syntax checking doesn't seem to evaluate those directives and the IDE claims there was a fatal "can't locate xyz.pm" error, despite the fact that the script runs fine.

One way to fix this is to add the module path using the "Additional Perl Import Directories" under <Edit><Preferences><Languages><Perl> .. but that is a global directive, not project specific, which leads to all kinds of interesting problems when module names collide, for instance when working with a previous release of the ported product (maintenance mode) ...

So, how can I configure the Komodo IDE to store "Additional Perl Import Directories" [the @INC path for syntax checking] with the project?

ericp
ActiveState Staff
Tue, 2009-05-19 11:37

http://bugs.activestate.com/show_bug.cgi?id=83165 (still in progress)

Here's what works:

Create a new project in the directory you're working in.

Using the project's properties|Languages|Perl tab, add the
paths you want Komodo to check.

If it's a "live folder" project, your main file will be a
member of the project. The bug seems to be that the
syntax-checker doesn't find the new paths for that project.

I created a new file at the same location as the old file,
with the same contents, and Komodo did find the new paths.

- Eric