Fails to run after fresh install

Posted by t.j. on 2009-04-16 09:07

Hi,I tried a fresh install of Active Python 2.6 on my Windows XP box and upon starting the python ide or just a python shell, I get the following error message (I saw something like this on the active perl forums, but didn't see how it would apply here):
"
C:\Apps\Python26\python.exe

This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
"

I did try reinstalling, both as a repair and just reinstalling from scratch, but the problem persists. Active TCL and Active Perl worked fine. Any thoughts?

Thanks

sridharr | Thu, 2009-04-16 09:36

t.j. | Thu, 2009-04-16 10:04

Well, it was good thought. I just installed the vs runtime, as per the suggestion. Repaired the active python installation and had the same problem. Uninstalled it and did a fresh install again. Same thing. Weird. Any other ideas?

sridharr | Thu, 2009-04-16 10:23

Hmm, I can only suggest that you try the SP1 redistributable. If you are using 64-bit Windows, then you need the corresponding redistributable. Both links can be found at

http://mail.python.org/pipermail/python-list/2009-February/702554.html

BTW, I cannot repro this on my end (fresh WinXP install).

t.j. | Thu, 2009-04-16 10:31

Hi Sridharr,

I used the 32 bit SP1 and that worked. Thanks for your help! (This was a fresh XP install as well, so I was just in the process of getting everything set up on it.)

sridharr | Thu, 2009-04-16 10:36

Ok; did you have Windows XP Service Pack 3 installed prior to trying this?

Cheers,
Sridhar