Error with Perl Package Manager

Posted by novice111 on 2008-09-23 14:18
Forums: PPM | OS: Windows XP Pro

Total newbie to Perl here.

I just downloaded ActivePerl for Windows so that I could test out a Perl application.

When I try running the program, it says it can't locate Sys/Syslog.pm, which I assume is a Perl Package. I tried loading the Perl Package Manager but I receive the following error in the general Window program crash alert message that asks you you want to tell Microsoft about the problem:

Perl Command Line Interpreter

Perl Command Line Interpreter has encountered a problem and needs to close. We are sorry for the inconvenience.

I am using ActivePerl 5.10.0 Build 1004 on Windows XP Pro. I have already tried re-downloading and re-installing.

mensaiq | Tue, 2008-10-07 18:09

You are correct in assuming Sys/Syslog.pm is a missing package. ppm would be the correct way to get it normally, but are you sure you want to use that package? It's not in Activestate's repository and CPAN indicates it's for UNIX systems.

I am having a problem running ppm from 1004 on XP Pro as well. I uninstalled 1004 and went back to 1003 and all is fine now. In 1004, I am getting a win32 exception in wperl.exe. Haven't had time to debug it. Since 1003 is working, I'll stay there for a while; you might try the same.