Does Komodo support RVM or not?

Posted by hamannp on 2010-12-18 14:21

I've seen this question asked before, but it has not been answered. Does Komodo support RVM or not? For me at least, and hopefully every other rubyist, this question is the same as asking whether or not it supports ruby at all. I really like Komodo, and I need a decent editor for Mac.

I tried pointing to a specific VM in the standard .rvm directory. Unfortunately, I can't select it no matter how hard I tried as it won't show hidden directories. I can't type it in the box either [ that would be a product defect, imho ]. I tried symlinking, but I got an error message saying that it doesn't recognize it as a valid VM. But beyond that, it shouldn't be this hard. RVM is now a best practice in the Ruby community. Supporting ruby means supporting RVM.

Could someone please tell me specifically how to use RVM with Komodo on Mac? Would someone from Activestate, if you're out there, please answer when you will have proper support for RVM? If it is not on your roadmap, may I humbly suggest that you STOP marketing Komodo as having ruby support.

Regards.
--Paul

EDIT: I finally figured out a workaround after a bunch more Googling. Not ideal, but it seems to work well enough. I hope this saves someone else some time. Disclaimer: no guarantee that it won't have any side-effects with Komodo.

Add this line below to your ~/.profile and type "source ~/.profile" at your shell prompt to load it immediately.

alias komodo='open -a "Komodo Edit"'

From there, type "rvm use ree( or rbx, or 1.9.1, or whichever version you want)"

To confirm that it's using the appropriate VM, type "cmd r" to open the command dialog and type "ruby -v" and hit enter. You should see your desired VM. For extra credit, go to "Komodo | preferences | languages | ruby". It may, or may not, have your vm correctly selected. In my case, it listed multiple ( but not all ) rvm managed rubies plus the system ruby. Typing 'cmd r' and then 'gem list' showed that it was indeed using the desired ruby. All my rvm rubies have the same gems, system does not.

ericp
ActiveState Staff
Mon, 2010-12-20 11:41