Conflict error installing Tk-TableMatrix-1.23 thru PPM

Posted by bhalstead1 on 2008-09-03 18:19
Forums: PPM | OS: Windows

I am trying to install tk-tableMatrix thru ppm on the following version of active state perl.

ActivePerl-5.10.0.1003-MSWin32-x86-285500.msi
PDK-Deployment-6.0.2.203380.msi

I am getting the following ppm error message. Is there any way to resolve this? Thanks, Bruce

Installing package ...
Downloading Tk-TableMatrix-1.23 ... done
Unpacking Tk-TableMatrix-1.23 ... done
Generating HTML for Tk-TableMatrix-1.23 ... done
Updating files in site area ... failed
Installing package failed

ERROR: File conflict for 'C:/Perl/site/lib/auto/Tk/pTk/extralibs.ld'.
The package Tk has already installed a file that package Tk-TableMatrix
wants to install.

jujinp | Thu, 2010-04-15 01:32

grahams
ActiveState Staff
Thu, 2010-05-13 16:09

You've also got a fatal mismatch. PDK 6 will not support Perl 5.10. Upgrade to the latest version.