Cannot instal modules

Posted by psailboat on 2010-05-05 02:47
Forums: PPM | OS: Windows XP Pro

I download a module but get message: "ppm install failed the ppd does not provide code to install for this platform" when I try

ppm install date-manip-6.11.ppd

How do I get round this? I can't use PPM as we have a strogn firewall and reverse proxy.

troyt | Wed, 2010-05-05 13:22

Looking at the build status of this module here:

http://ppm4.activestate.com/idx/DATE...DAY.html

...indicates that the only Windows PPM package we have for this version of the module is for ActivePerl 5.12 MSWin32-x64. If you're on a 32bit system, or using an older version of ActivePerl, there's no working package available.

Download the ppmx file that matches your version of ActivePerl (5.8, 5.10, or 5.12) and platform (x86 or x86_64) from the link above. You may have to go back to version 5.56 to get the package you need. Mouse over the Windows icons in the PPMX (first) column to see the package version info.