ActivePerl on Linux

Posted by wbmp123 on 2008-11-25 08:45

I've downloaded version 5.10 (rpm download) onto my Linux machine. I've put it onto a directory called /opt/pdk/ and in a shell I navigated to this directory and ran rpm -i ActivePerl......rpm. It never gave any feedback but there is now a directory underneath /opt/ called ActivePerl-5.10. If I do a perl -v at the shell prompt it still gives me version 5.6. First off how can I have the system recognize perl 5.10 as being the active version of perl (if I wanted or needed to)?
The core reason in coming in here was, however, to ask about problems I'm getting trying to install the PDK (7.3) for Linux. I had it installed before (an older version). I moved the download for Linux (x64) into the opt/pdk directory as well and tried running (gunzip -c PDK....tar.gz | tar xvf -) on it from within a shell in the directory and it seems to have worked. It created a new directory within called opt/pdk/PDK-Pro-7.3.0.287519-linux. If I try running ./install.sh within this directory I get the follwoing error message :
/lib/i686/libc.so.6: version 'GLIBC_2.3' not found (required by ./setup)
Can anyone tell me what this error message is referring to and how to successfully install this new version of PDK? If I need to restart the process I'm perfectly fine with that as long as I can get this up and running as soon as possible. I would appreciate any help that you can give.