5.10 and DB_File

Posted by halindrome on 2008-09-22 09:40

It appears that there is no PPM module for DB_File under activeperl 5.10 (build 1004). A little research shows that ActiveState claims DB_File is part of the "Core" on 5.10 [1] - which is great. However, there does not appear to be a DB_File.pm file anywhere, and 'perl -MDB_File -e 1' returns an error that indicates perl cannot locate that module.

Am I missing something here, or did this module accidentally not get included in the distribution?

[1] http://ppm.activestate.com/BuildStatus/5.10-D.html

ActiveState Staff
Tue, 2008-10-07 15:56

That link is a status report for the old repositories, which are being phased out. One of the many reasons they are on the way out is the number of inaccuracies in their reports. DB_File is intended to be core in all versions except Windows (due to an unmet dependency on Berkely DB libraries with Windows).

The new build repositories report their status here:
This one is accurate. Unfortunately, it shows that there are problems blocking the build of DB_File on all platforms except 5.10 for Linux-64 bit. We have an open bug for the issue.

ewmjc | Fri, 2010-03-05 08:00

2010 and still no 64-Bit DB_File ppm for Windows. I've tried compiling it from source without success so far, possibly simply due to lack of skill. Has anybody has success? Is there any fundamental reason why it is not possible to get a working version?

Michael Collinson

ActiveState Staff
Tue, 2010-04-06 15:11

It's now building for OS X 5.8 and 5.10 and for 64 bit Linux 5.10, but failing everywhere else.

Since it won't build for most platforms, DB_File been dropped from the list of core ActivePerl modules.

halindrome | Tue, 2010-04-06 15:38

Perhaps this is a simple configuration problem in the build environment? DB_File is a venerable module. It has been part of perl forever, more or less. And it is readily available from other repositories so *they* must have figured out how to build it?

ActiveState Staff
Thu, 2010-05-13 15:22

I assume you mean this:


Only Trouchelle for 5.8 is current. Everything else is frozen at old versions of DB-File.
Trouchelle's 5.10 version is from Jan 2009.

DB-File only supports Berkeley version 1 and the version 1 features when used with newer releases of Berkeley. Berkeley 2+ should really be using the BerkeleyDB module instead. Since Berkeley is at 4.8.24 last I heard, it's hard to justify DB-File.

pauls | Fri, 2010-05-28 07:59

How do you fix this problem? I have installed 5.10 on win7-64. The Perl Package Manager shows DB_File v. 1.820 in the installed column, but it's available column is empty. What does this mean? It is very misleading.

I am unable to repair this - it's a complete showstopper. I need to test locally some problems for movabletype 2.661 that needs this module. It is showing this module as not installed.

Should I uninstall this version of perl and try another? What else will install easily on win7-64?

pauls | Fri, 2010-05-28 07:59

Fixed my problem by moving the database to MySql.