XML DOM requires libwww-perl but that is "core" for 5.8.8

Posted by DigitsRMyLife on 2007-07-13 14:50
Forums: PPM | OS: Windows XP Pro

I'm running WinXP Pro SP2, ActiveState v5.8.8 binaryBuild 820, ppm4
I need to install XML-DOM package which I've downloaded from ppm.activestate.com and found the other dependencies (that was fun). I'm behind a firewall so don't have internet access thru gui (I set up http_proxy environVariable but it doesn't seem to help).

When I try to install I get this error:

C:\Perl\mylib\XML-DOM-1.44>ppm install XML-DOM.ppd
ppm install failed: Can't find any package that provide libwww-perl for XML-DOM

When I look up libwww-perl for 5.8.8, the zips indicate it is "core". I tried to "cheat" and I can download for 5.0 and 5.6.6 but they won't install

C:\Perl\mylib\libwww-perl>ppm install libwww-perl.ppd
ppm install failed: The PPD does not provide code to install for this platform

which is probably good.
Does this mean I need to download the CPAN library and build it myself? (ugh)

Thanks in Advance for your help

gasi | Thu, 2007-11-08 07:41

Hi, I had the same problem, but I could solve it be reinstalling the libwww-perl package via ppm.
You'll find the PPM-Package at http://www.bribes.org/perl/ppm. For installation there are also other packages needed, that you'll also find there.

I hope it'll work!