tying to install latest PERL on Windows Vista, and it's not working!

Posted by spitalny on 2007-03-20 15:28

Just got a new machine, I am trying to install Activeperl. I get the following error message:

"this installation package is not supported by this processor. Contact your product vendor"

I am using the following machine:

Dell Precision 390
CPU: Intel X6800 Dual Core
Operating system: Windows Vista

I am pretty desperate to get this to work. So, any help greatly apprciated.

By the way, I tried the following install file:

ActivePerl-5.8.8.820-MSWin32-x64-274739.msi

Thanks!

P.

kevinw
ActiveState Staff
Wed, 2007-03-21 13:39

Hi P,

The error message is somewhat misleading -- it's the message the Microsoft Installer (MSI) service gives when you try to install a 64-bit package on a 32-bit version of Windows, regardless of the processor on the system.

Download and install the x86 package and everything will work as you expect.

Cheers,

kjw

baby1acc | Tue, 2007-11-20 16:51

Hi,

I am also having a problem installing activePerl on Windows Vista.

I downloaded and tried to install x86 package but I get the following error:

"This installation package could not be opened.Contact the application vendor to verify that this is a valid Windows Installer package"

I am working on:
HP Pavilion dv6426us
CPU:Intel Centrino Duo core
OS:Windows Vista

I would appreciate any help to solve this problem.
Thanks in advance!
BA

spitalny | Tue, 2007-11-20 17:12

Hi BA,
I don't know much more to tell you except that I did exactly what I was told in the post from Kevinw and it solved my problem. It is likely you are trying to install the 64 bit version on a 32 bit operating system. Try downloading the 32 bit version and try to install that !

Good luck!

P.

jeyan | Fri, 2008-03-28 14:38

Jey.R

jeyan | Fri, 2008-03-28 14:42

Hi , I tried to installed mysql driver for perl and i got this error
"this installation package is not supported by this processor. Contact your product vendor"

OS - 64bit vista

please help me to fixed this proplem......I tried with both x86 and x64 perl and got the same error message.
Jey.R