trouble installing packages -- RawInflate broken?

Posted by trillich on 2008-05-28 12:25
Forums: PPM | OS: Windows XP Pro

trouble installing packages (both CPAN and PPM) fail in IO::Uncompress::RawInflate? anybody seen this or have a suggestion?

i tried a 'repair' style reinstall of activeperl, no good...

C:\>ppm install SOAP::Lite
Downloading SOAP-Lite-0.69...done
Downloading MIME-Lite-3.021...done
Downloading MailTools-2.03...done
Downloading Email-Date-Format-1.002...done
Downloading MIME-Types-1.24...done
Downloading TimeDate-1.16...done
Unpacking SOAP-Lite-0.69...ppm install failed: Can't call method "value" on an undefined value

C:\>cpan SOAP::Lite
CPAN: File::HomeDir loaded ok (v0.69)
CPAN: Storable loaded ok (v2.18)
Going to read C:\Perl\cpan\Metadata
  Database was generated on Sat, 24 May 2008 08:30:29 GMT
Running install for module 'SOAP::Lite'
Running make for M/MK/MKUTTER/SOAP-Lite-0.710.05.tar.gz
CPAN: Digest::SHA loaded ok (v5.45)
CPAN: Compress::Zlib loaded ok (v2.008)
Can't call method "value" on an undefined value at C:\Perl\lib/IO/Uncompress/RawInflate.pm line 64.

C:\>perl -v

This is perl, v5.10.0 built for MSWin32-x86-multi-thread
(with 3 registered patches, see perl -V for more detail)

terziyski | Fri, 2008-05-30 14:48

Yes, as of 28.05.2008 on my Cygwin under WinXP Pro I get the same error. I supose it is a result of updated dependent package:

cpan> install Bundle::CPAN
Going to read /home/Ivo/.cpan/sources/authors/01mailrc.txt.gz
Can't call method "value" on an undefined value at /usr/lib/perl5/vendor_perl/5.8/IO/Uncompress/RawInflate.pm line 64.