Problems adding Roth repository

Posted by cheesegrits on 2008-02-11 10:19
Forums: PPM | OS: All / Any

I just installed perl 5.10.0 on a W2k3 box. When I try and add the Roth repository, it seems to see all the packages:

Downloading Roth packlist ... redirect
Downloading Roth packlist ... done
Downloading Roth GDBM_File PPD ... done
Downloading Roth Win32-AdminMisc PPD ... done
Downloading Roth Win32-API-Prototype PPD ... done
Downloading Roth Win32-Daemon PPD ... done
Downloading Roth Win32-EventLog-Message PPD ... done
Downloading Roth Win32-Exchange PPD ... done
Downloading Roth Win32-Message PPD ... done
Downloading Roth Win32-ODBCBETA PPD ... done
Downloading Roth Win32-Perms PPD ... done
Downloading Roth Win32-Pipe PPD ... done
Downloading Roth Win32-RASAdmin PPD ... done
Downloading Roth Win32-Scheduler PPD ... done
Downloading Roth Win32-Tie-Ini PPD ... done
Downloading Roth Win32-Volume PPD ... done
Synchronizing Database ... done

But ... the packages don't show up in my available list, and in the repository preferences dialog, it shows 0 for # Pkgs.

On an otherwise identical machine, only with perl 5.8.8, the Roth packages show up just fine.

I've tried removing and re-adding the repo on the affected machine, but it's always the same result. It downloads the PPD's, syncronizes the db ... but 0 packages show up. If I do the same on the 5.8.8 box, it works every time.

I'm about to uninstall 5.10.0 and drop & punt to 5.8.8, as I desperately need Win32-AdminMisc installed today ...

-- hugh

grahams
ActiveState Staff
Tue, 2008-04-29 11:02

It looks like the Roth repository does not have 5.10 compatible versions yet.

rolisk19@msn.com | Mon, 2012-10-15 05:09

I have added the sisyphusion repository and it reflects a Non-zero # Pkgs.
When I try and add the University of Winnipeg - it always indicates # of Pkgs of Zero.

Is PPM - only attempting to list the number of packages complient with the version of Perl that is installed?

It appears that when PPM starts - it stops attempting to Syncronize the repository store of University of Winnipeg.

When I look at this repository I see a number of packages I would be interested in.
Am I going to have to install these manually?

grahams
ActiveState Staff
Thu, 2012-10-18 16:11

PPM pulls pre-built binaries, so it can only install modules which are compatible with the local version of Perl.

If a module you need is not listed in the known PPM repositories, then you will need to build it locally. The "cpan" script may be able to build it if you have all the dependencies installed. In some cases, you may need to fall back to a full manual install, as is typically described in the READMEs provided on CPAN.