PPM user area doesn't exist?

Posted by Harkius on 2007-04-05 15:33
Forums: PPM | OS: Windows XP Pro

Hi,

I am having a little difficulty with PPM. I have installed ActiveState's distribution off of the web, and I installed to a directory called C:/Program Files/Perl. I fixed my PATH in Windows to recognize space-including file paths, but now PPM is having a fit with installing new packages.

Specifically, when I open the program, it seems to synchronize fine, but then the program hangs. I cannot see local packages. I can access menu items fine. When I go to Preferences to add sites to check, I get the following messages:

Install area 'user' does not exist at C:/Program Files/Perl/lib/ActivePerl/PPM/Client.pm line 175.

Install area 'user' does not exist at C:/Program Files/Perl/lib/ActivePerl/PPM/Client.pm line 175.

while executing
"::perl::CODE(0x55ff268)"
(menu invoke)

Obviously, I need a directory C:/Program Files/Perl/lib/ActivePerl/PPM/user/

I made this, but I am still having problems.

Help, please?

Thanks,
Harkius

Matthias | Mon, 2008-09-22 07:23

Hi Harkius,

I just experienced exactly the same problem and was able to find a work-around. At the command line, type:

ppm config list

You will find that the value of gui.install_area is probably set to user. If you type:

ppm area list

you will notice that user is not listed as a valid area. This is probably exactly the same reason why PPM crashes if you invoke the GUI.

I got around that problem by doing the following.

  1. Create a temporary directory called user somewhere on your machine, e.g. C:\user.
  2. Set the environment variable LIB5PERL to this directory, e.g. C:\user.
  3. Restart PPM and open the Edit/Preferences-dialogue.
  4. Explicitly activate the radio button site, or at least any site pointing to a valid installation area.
  5. Close PPM and remove both, the value C:\user from the environment variable LIB5PERL as well as the directory itself.

This worked at least for me, hope this could help you too.

Regards,
Matthias

ogsy | Wed, 2009-03-04 15:02

This command worked for me when the previous suggestion didn't work.

ppm config gui.install_area site