PPM UPgrade problem

Posted by pathanks on 2007-01-22 07:07

I am new to Perl and have a question. I recently used PPM (v3.4) to install the Class-DBI and DBD-ODBC modules. When I run the upgrade, I notice 2 items that will not upgrade. Do I need to worry about them? They are;

"Class-DBI 3.0.6: new version 3.6 available in ActiveState Package Repository" It will launch the installer, but when it is finish, the version never changes.

"Term-ReadLine-Perl 1.2.3.2: new version 1.0302 available in ActiveState Package" I will get a permission error because PPM is using the module.

I have tried ppm upgrade [module name] -install -precious -force in many variations with no luck.

I am running Perl v5.8.8 build 817 on Windows XP. I have also tried it on another system running Windows Server 2003 with the same results.

Any help is appreciated.

kevinw
ActiveState Staff
Tue, 2007-01-23 10:56

You will probably want to upgrade to ActivePerl 5.8.8.819. It introduces a new major version of PPM that sidesteps some of these issues. If you want a PPM3-like interface with PPM4 simply use the "ppm-shell" command from the command prompt.

Cheers,

kjw

pathanks | Tue, 2007-01-23 10:59

Thanks for the tip. I'll give it a shot.