PPM opening as read-only

Posted by thslone on 2008-07-30 09:49
Forums: PPM | OS: OS X 10.4 (Tiger)

I have just installed ActivePerl (OS X) and am trying to add modules using ppm. I am logged in as administrator. When I start ppm, I immediately get the following message:

All activated install areas are read-only. You cannot currently install or remove packages. Try enabling the uninitialized Areas in the Preferences dialog

When I open the Preferences dialog, I get a small window that has a tab that says "Areas" and an "OK" button. There are no options to do anything in this dialog except click on OK to close the window.

I also tried starting ppm as superuser, but it did not start up at all.

How do I fix this read-only problem?

grahams
ActiveState Staff
Fri, 2008-09-19 15:01

This is a bug in the 1003 installer for OS X.

There is a work-around.
If you are user $ID, then open a terminal window. At the command line:
mkdir /User/$ID/Library/ActivePerl-5.10
chmod 777 /User/$ID/Library/ActivePerl-5.10
mkdir /User/$ID/Library/ActivePerl-5.10/lib
chmod 777 /User/$ID/Library/ActivePerl-5.10/lib
ppm area init Library

You may also observe a bug in the PPM gui color assignment in the 1003 release which is not fatal and can be ignored.

Both of the issues should be corrected in the 1004 installer.