PPM & MSI in windows

Posted by joepell on 2007-04-05 11:46

I bought the activeCD and tried to upgrade from 5.6 to 5.8.8 build 820. The MSI file on the DVD didn't work at all just caused the computer to hang up requiring a hard reboot. I got Perl installed by downloading the MSI from the web site. Now I need to rebuild my packages and when I run PPM from the command line in a DOS window a bunch of lines scroll by and then I am returned to the desktop. If I try to run PPM from the desktop with a START->RUN ppm a DOS window pops up and a bunch of lines scroll quickly through it and then it just stops. I can close the window and windows is still active. Funny thing is nothing I have attempted to do with the DVD has worked yet. Any ideas on how to get PPM up and running would be appreciated.

Old Gateway computer (P2-400) running windows 98 se
I am using the sambar server to dole out the web pages
When the server tries to access my script it hangs right away because
it can't find the Readonly module. That's what I'm trying to get with PPM.

Joe

kevinw
ActiveState Staff
Mon, 2007-04-09 12:21

Hi Joe,

You can't directly upgrade from 5.6 to 5.8 -- too many things change, including the modules. Here's the way to sanity:

  • uninstall all versions of ActivePerl using the Add/Remove Programs control panel
  • delete the ActivePerl installation directory and all files and directories therein
  • install the new version of ActivePerl
  • re-install the modules using PPM

The problems with PPM sound like modules failing because they're 5.6 modules trying to be loaded by a 5.8 interpreter or vice versa.

Cheers,

kjw