ppm fails for users with non-ASCII usernames

Posted by gisle on 2006-12-05 02:19
Forums: PPM | OS: Windows

ppm in ActivePerl 819 on Windows fails to start up for users with non-ASCII user names. The error message displayed is something like:

  ppm gui failed: DBI connect('dbname=C:\Documents and Settings\<username>
    \Application Data/ActiveState/ActivePerl/ppm-MSWin32-x86-multi-thread-5_8.db',
    '',...) failed: unable to open database file(1)

This is caused by limitations in perl's handling of Unicode and we plan to address this issue in the upcoming release. The recommended workaround is to tell PPM to access its state database from a path consisting of plain ASCII characters only. It is achieved by setting the ACTIVEPERL_PPM_HOME environment variable to the name of a directory that ppm should use. For instance:

   C:\> set ACTIVEPERL_PPM_HOME=C:\Perl\Temp
   C:\> ppm

kevinw
ActiveState Staff
Tue, 2006-12-05 16:50

Hello Gisle,

I created a FAQ for this so it will show up on the FAQ list. Thanks for putting this together.

Cheers,

kjw