ppm does not work after install

Posted by dysmas on 2008-03-18 05:24
Forums: PPM | OS: Windows 2000 Pro / Server

I just installed ActiveState Perl 5.10.0.1002 Win 32 and tried to launch ppm.

Either with the gui command or with the command line (ppm install PAR) I get the same error message :

ppm install failed: DBI connect('dbname=c:\winnt\PARAMâ•š~1\APPLIC~1/ActiveState/ActivePerl/1002/ppm-MSWin32-x86-multi-thread-5_10.db','',...) failed: unable to open database file(1)

I had exactly the same error with ActiveState Perl 5.8

The directory c:\winnt\... \1002 is correctly created, but nothing inside.
I wonder if this may have something to do with the fact that I have a French Windows, with an accentuated character in the above path which should be :

c:\winnt\PARAMè~1\APPLIC~1/ActiveState/ActivePerl/1002

Or a problem with slashs instead of anti-slashs ?

But I don't see what I can do to create manually the desired database.

Thanks if you have any idea

dysmas | Tue, 2008-03-18 09:33

I tried to install the same install file on a computer running the same version of Windows 2000 Pro, but which does not have a "paramètres locaux" directory in WINNT. There ppm works perfectly and the database was installed in "Documents and Settings/Administrateur/Local Settings/Application Data/Active State/Active Perl/1002".

I tried to copy this database in the 1002 directory of the first installation, but it did not work.

I am quite sure the question is about this accentuated character because PARAM╚~1 is incorrect, we should have paramè~1

grahams
ActiveState Staff
Tue, 2008-04-29 10:59

You can set the ACTIVEPERL_PPM_HOME environment variable to
point to a directory without extended Unicode characters in its name and PPM
will try to maintain its database in this directory instead.

Example:

set ACTIVEPERL_PPM_HOME=c:\perl\temp

dysmas | Wed, 2008-04-30 08:49

Hello,
Thanks a lot for your answer, it works perfectly !