Perl/Tk on v5.10.0

Posted by IvanBerti on 2008-01-08 03:52
Forums: PPM | OS: Windows Vista

Having installed ActivePerl version 5.10.0 I notice the Perl/Tk bundle does not appear to be included as it was under 5.8.x. Neither does there appear to be a version of Tk installable via ppm and the standard repository. Where can I obtain the Tk bundle for 5.10.0?

MarcZ | Wed, 2008-01-09 08:59

You may want to try PPM again.

I was able to grab Tk from the ActiveState Repository using PPM using the Build Perl 5.10.1001.

Tk Version 804.027

IvanBerti | Thu, 2008-01-10 05:25

Thanks for that. I can confirm I have successfully downloaded Perl/Tk via ppm.

But it makes me think: is Tk now bundled with the ActivePerl 5.10.0? What other modules/bundles might be missing from the ActivePerl distribution I loaded? Should I reload it?

MarcZ | Thu, 2008-01-10 06:51

The Perl 5.10 build is not binary compatible with the older builds, so any previous installed module containing binary code will not run.
(This is stated in the 5.10 Change log in the documentation.)

PPM can show what modules are installed.

What I did on one Machine:

XCopy C:\Perl to C:\Perl-822
( that way you can go back if needed )

un-install Perl 5.8.8
install Perl 5.10

Then ran PPM
added other repositories.
Installed modules.

(Not all modules are available yet...)

michael | Tue, 2008-01-15 21:53

I don't understand, why such substantial modules are not intergrated into the 5.10, when it is released. TK is over years a part of the distribution and we use it also since years.

IvanBerti | Wed, 2008-01-16 08:26

Yes, it was bundled with version 5.8.x.

Maybe the folks at ActiveState haven't got round to including it with their standard distribution (or maybe it is now!). Or perhaps have thought it should be a custom feature.

I have the same feeling with some of the non-proprietary DBD modules (eg DBD::CSV or DBD::ODBC). But then I'm mainly a trainer so I'm looking for a vanilla installation to have such features, without having to customise the installation.

dhardwhare | Fri, 2008-03-14 09:04

How can I obtain that Perk/Tk bundle without using ppm? The computer that I need it on cannot be connected to a network, so I need the alternative approach.

Thank you,

Singer | Fri, 2008-08-29 02:05

you can go directly to http://ppm4.activestate.com/ to find the TK module package, then use ppm to install it

m_for | Fri, 2009-02-27 16:27

this machine (OS X 10.4) is blocked from using ftp, so I downloaded Tk-804.028_501 and here's where I'm stuck. I have downloaded and installed X11User.dmg and I have installed all of the developer CD goodies.

Computer:/Tk-804.028 usx$ perl Makefile.PL
perl is installed in /System/Library/Perl/5.8.6/darwin-thread-multi-2level okay
PPM for perl5.008006
Test Compiling config/perlrx.c
Test Compiling config/pmop.c
Test Compiling config/pregcomp2.c
Test Compiling config/signedchar.c
Test Compiling config/Ksprintf.c
Test Compiling config/tod.c
Test Compiling -DTIMEOFDAY_TZ config/tod.c
TZ gettimeofday()
Using -L/usr/X11R6/lib to find /usr/X11R6/lib/libX11.6.2.dylib
Cannot find X include files via /usr/X11R6/include
Cannot find X include files anywhere at ./myConfig line 369.
Compilation failed in require at Makefile.PL line 37.
BEGIN failed--compilation aborted at Makefile.PL line 39.
Computer:/Tk-804.028 usx$

I do have a Computer:/Developer/SDKs/MacOSX10.4u.sdk/usr/X11R6/lib/libX11.6.2.dylib

when I try to change ./myConfig with:
$inc = "/Developer/SDKs/MacOSX10.4u.sdk/usr/X11R6/include/";
$xlib = "/Developer/SDKs/MacOSX10.4u.sdk/usr/X11R6/";

I get the same errors...

In the end I hope to be able to write a perl program that uses "use Tk::DialogBox;" on my Vista and Mac. All I get now is:

Can't locate Tk/DialogBox.pm in @INC (@INC contains: /System/Library/Perl/5.8.6/darwin-thread-multi-2level /System/Library/Perl/5.8.6 /Library/Perl/5.8.6/darwin-thread-multi-2level /Library/Perl/5.8.6 /Library/Perl /Network/Library/Perl/5.8.6/darwin-thread-multi-2level /Network/Library/Perl/5.8.6 /Network/Library/Perl /System/Library/Perl/Extras/5.8.6/darwin-thread-multi-2level /System/Library/Perl/Extras/5.8.6 /Library/Perl/5.8.1 .) at before_v2.pl line 1.
BEGIN failed--compilation aborted at before_v2.pl line 1.

awen | Wed, 2008-06-25 05:39

perl/tk

grahams
ActiveState Staff
Fri, 2008-09-19 15:55

You won't find Tk in 5.10 releases because the original author died in 2006.

Perl/Tk is so big that nobody in the community has the time to take it on. Several people step in if it needs critical fixes, but Tk for Perl is steadily loosing ground against Tcl/Tk and Perl core. ActivePerl 5.8.8.824 ships with an important security patch applied to Tk, but otherwise it hasn't been touched in years. It's now considered unmaintained (but still very good) code.

It was easier to spawn a new fork from the Tcl Tk (Tkx) than to update Perl Tk, so Tkx is the accepted standard for 5.10.

vishnu | Fri, 2009-06-12 14:58

Hello folks,

I am working on build v5.10.1005

tried installing tk package Tk-804.028_501 , but then during nmake i faced an error--> " Dont know how to make 'c:Documents'"

Obviously "perl Makefile.pl" has not worked correctly. I also see that during the execution of the 'perl Makefile.pl ' stmt several files are not recognized and error thrown is "'cl' is not an internal or external command"..

So I am guessing Tk-804.028_501 was not meant for v5.10.1005

So guys pls help me out. What version should i use to make ptk work with build v5.10

grahams
ActiveState Staff
Tue, 2009-07-14 14:05

Should only be considered for testing purposes. If you're testing Tk you probably already know enough to hack the makefile.pl as needed to get it to install on Windows.

If you must use Tk on 1005, you'll find that the stable 804.028 version available from PPM is much simpler to install.