Package failing to build - Image-Magick

Posted by SaltyFoam on 2007-07-13 14:22
Forums: PPM | OS: All / Any

I am wanting to use the FFmpeg package but looking at the available packages from ActiveState shows that this one is not currently building. Following the trail of dependencies, the culprit appears to be caused by an invalid command line argument when building Image-Magick...

Microsoft (R) Program Maintenance Utility Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.

cp Magick.pm blib\lib\Image\Magick.pm
AutoSplitting blib\lib\Image\Magick.pm (blib\lib\auto\Image\Magick)
D:\cpanrun\build\5-8-0\bin\perl.exe D:\cpanrun\build\5-8-0\lib\ExtUtils\xsubpp -typemap D:\cpanrun\build\5-8-0\lib\ExtUtils\typemap Magick.xs > Magick.xsc && D:\cpanrun\build\5-8-0\bin\perl.exe -MExtUtils::Command -e mv Magick.xsc Magick.c
cl -c -I../ -I.. -I/usr/include/librsvg-2 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/include/graphviz -I/usr/include/freetype2 -I/usr/include/libxml2 -nologo -Gf -W3 -MD -Zi -DNDEBUG -O1 -DWIN32 -D_CONSOLE -DNO_STRICT -DHAVE_DES_FCRYPT -DPERL_IMPLICIT_CONTEXT -DPERL_IMPLICIT_SYS -DUSE_PERLIO -DPERL_MSVCRT_READFIX -g -O2 -Wall -W -pthread -MD -Zi -DNDEBUG -O1 -DVERSION=\"6.3.2\" -DXS_VERSION=\"6.3.2\" "-ID:\cpanrun\build\5-8-0\lib\CORE" -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c
Command line warning D4025 : overriding '/O1' with '/O2'
Command line error D2021 : invalid numeric argument '/Wall'
NMAKE : fatal error U1077: 'cl' : return code '0x2'
Stop.
o library found for -lglib-2.0
Note (probably harmless): No library found for -lxml2
Note (probably harmless): No library found for -lgvc
Note (probably harmless): No library found for -lz
Note (probably harmless): No library found for -lpthread
Note (probably harmless): No library found for -lm
Note (probably harmless): No library found for -lpthread
Writing Makefile for Image::Magick