nmake of packages resulting in Undefined UpdateHTML_blib error

Posted by toorbit on 2006-10-17 12:45
Forums: PPM | OS: Windows XP Pro

I'm trying to build and install a couple packages, including Test-Class-0.19 and when I run Windows nmake I get the following error:

Undefined subroutine &main::UpdateHTML_blib called at -e line 1.
NMAKE : fatal error U1077: 'C:\WINDOWS\system32\cmd.exe' : return code '0xff'
Stop.

Any ideas why this is failing?

BTW, I'm running ActivePerl-5.8.8.819

Thx!

kevinw
ActiveState Staff
Tue, 2006-10-17 12:58

You're much better off to install packages like Test-Class using PPM rather than CPAN. PPM packages are pre-built and don't run into some of the problems that CPAN packages can. From a command prompt, type "ppm" to enter the PPM GUI (on build 819 and later) or "ppm-shell" to enter the console-based version (which is what plain "ppm" does prior to build 819). Help is available from the menus in the graphical client, or by typing "help" in the console client.

Cheers,

kjw

hash1024 | Fri, 2006-11-10 12:58

By default @INC = (qw{C:/Perl/site/lib C:/Perl/lib .})

so it searches for modules in this order, at least as far as I remember. The problem is that C:/Perl/site/lib/ActivePerl/DocTools.pm doesn't have UpdateHTML_blib() function.

But this function exusts in C:/Perl/lib/ActivePerl/DocTools.pm, so you have two ways of fixing it:
- copy C:/Perl/lib/ActivePerl/DocTools.pm C:/Perl/site/lib/ActivePerl # which I did and it works
- modify makefile to correct @INC # didn't check but should work.

HTH,
Alex.

williamwu | Thu, 2010-03-04 23:08

I has solved this problem used by copy C:/Perl/lib/ActivePerl/DocTools.pm C:/Perl/site/lib/ActivePerl

Thanks.