.NET Compatible

Posted by AlisonRose on 2008-05-27 08:09

Hi,

We are running Active Perl 5.8.8.817 with a handful of packages on our servers ...

Carp-Clan.ppd
Bit-Vector.ppd
Date-Calc.ppd
DBI.ppd
DBD-Oracle.ppd
Datemanip.ppd
Net-Telnet.ppd
Parse-RecDescent.ppd
Spreadsheet-WriteExcel.ppd

We are going through our Windows updates and was wondering if any of the following .NET updates would affect Active Perl in anyway:

Microsoft .NET Framework 2.0 : x86 (KB829019)
Microsoft .NET Framework 2.0 Service Pack 1 (KB110806)
Microsoft .NET Framework 2.0 Service Pack 1 (KB110806)

Hope you can help. Many thanks, Alison

grahams
ActiveState Staff
Thu, 2008-05-29 14:22

ActivePerl itself does not use, and has no dependencies on .NET. If you are only using ActivePerl, you can use any .NET version you like or none at all.

However, the ActiveState PerlDevKit does have a component which uses .NET.

PDK 7.0 and lower require .NET1.1. There are known issues with these versions conflicting with security hotfixes for .NET 1.1 and .NET 2.0. SP1 for .NET 1.1 and SP1 for .NET 2.0 contain these security hotfixes as well. Updating either .NET 1.1 or .NET 2.0 to SP1 and will break old versions of PDK.

PDK 7.1 does not require .NET. The .NET tools were disabled for this release because of the problems mentioned above.

PDK 7.2 requires .NET 1.1 and .NET 2.0. SP1 is strongly recommended for both.