Missing module "logging" on Solaris install

Posted by rowan.bradley on 2007-06-08 00:06

I'm trying to install ActivePython on Solaris X86. I downloaded the the installer to a Windows machine, expanded it and FTPd the resulting directory to the Solaris box. I then tried to run install.sh, and got Import Error: No module named logging at line 33 in ./_install/py

Any idea what I'm doing wrong?

Does the directory ActivePython-2.5.1.1-solaris10-x86 (which was expanded from the .tar.gz file I downloaded) have to be put in a specific location on the Unix box?

I'm an absolute beginner with Unix, so this is probably something very simple...

Thanks for your help.

Rowan

trentm | Mon, 2007-06-11 09:03

Rowan,

Could you cut and paste the full shell output from trying to install? It is probably something straightforward.

Is it possible that not all files were FTP'd to the solaris box? Any reason to not FTP the .tar.gz package over and unpack it on the solaris box?

Trent

rowan.bradley | Tue, 2007-06-12 08:47

>Could you cut and paste the full shell output from trying to install?

Here it is:

-bash-3.00# ./install.sh
Traceback (most recent call last):
File "./_install.py", line 33, in
import logging
ImportError: No module named logging
-bash-3.00#

>Is it possible that not all files were FTP'd to the solaris box?

As far as I can see everything copied across properly.

>Any reason to not FTP the .tar.gz package over
>and unpack it on the solaris box?

Only that I know how to do this in Windows and have all the tools set up. I'm a complete novice at Unix...

Thanks for your help.

Rowan