Installing Crypt::SSLeay on 64-bit Vista

Posted by Dan Vann on 2007-03-11 15:55
Forums: PPM | OS: Windows Vista

I am trying to install Crypt::SSLeay on my Vista 64-bit machine but I am getting errors from ppm. This is what I type and this is what it tells me:

>ppm install http://theoryx5.uwinnipeg.ca/ppms/Crypt-SSLeay.ppd
ppm install failed: The PPD does not provide code to install for this platform

Is there any workaround for installing Crypt::SSLeay on my machine? I am running PPM version 4.01 and Activestate Perl v5.8.8 build 820. Any help would be greatly appreciated. Thanks.

kevinw
ActiveState Staff
Mon, 2007-03-12 12:30

Hi Dan,

It sounds like you're running the 64-bit version of ActivePerl. I'm not aware of anyone building PPM packages for 64-bit Windows yet. If you want to use packages in many of the PPM repositories I recommend uninstalling the 64-bit version and installing the 32-bit version of ActivePerl.

Cheers,

kjw