Installation Error for ActiveTCL8.4.14

Posted by praveenkumarg on 2007-01-04 02:32

I tried installing ActiveTcl (ActiveTcl8.4.14.0.272572-win32-ix86-threaded.exe) on Windows XP and I get an error :

error copying "C:/Downloads/Technical/ActiveTcl8.4.14.0.272572-win32-ix86-threaded.exe/uninstall.exe" to "C:/Tcl/lib/ppm/log/activetcl8.4-thread/uninstall.exe": permission denied
error copying "C:/Downloads/Technical/ActiveTcl8.4.14.0.272572-win32-ix86-threaded.exe/uninstall.exe" to "C:/Tcl/lib/ppm/log/activetcl8.4-thread/uninstall.exe": permission denied
while executing
"file copy -force $::SCRIPT_DIR/$::AT(UNINSTALLER) $logdir/$::AT(UNINSTALLER)"
(procedure "install_log" line 16)
invoked from within
"install_log [list MKDIR $installdir]"
(procedure "install_all" line 12)
invoked from within
"install_all [file join $srcdir payload] $installdir"
(procedure "do_install_modules" line 4)
invoked from within
"do_install_modules $::SCRIPT_DIR $::INSTALL_DIR $::DEMO_DIR"
(procedure "install_ready" line 127)
invoked from within
"install_ready $::BASE"
("9" arm line 1)
invoked from within
"switch -exact $state {
1 { incr state [intro $::BASE] }
2 { incr state [license $::BASE] }
3 {
# This page is always skipped when bac..."
(procedure "main" line 121)
invoked from within
"main"

I tried this multiple times and the problem repeats. I tried downloading the exe yet again but still the problem exists.

Can somebody tell me a workaround ???

Note: I downloaded the same on a different machine and the installation goes through fine.

kevinw
ActiveState Staff
Thu, 2007-01-04 10:47

Hi,

Have you tried running the installer as Administrator? That should take care of the permissions issues. I can't reproduce this on Win32.

Cheers,

kjw

praveenkumarg | Thu, 2007-01-04 11:54

Yes, I have administrator privileges on the system. I am seeing the same problem on another system too.
Not sure whats causing it. Works on some systems, doesn't on others.

BlairC | Fri, 2007-04-13 14:13

I have a new Lenovo ThinkPad X60s running Vista. Just installed Tcl 8.4.14.0 (running as administrator) and received the folling errors during installation.

ERROR: Unable to determine name of link file for "Tk"
ERROR: Unable to determine name of link file for "BWidget"
ERROR: Unable to determine name of link file for "IWidgets"
ERROR: Unable to determine name of link file for "Img"
ERROR: Unable to determine name of link file for "TCom - Chart"
ERROR: Unable to determine name of link file for "Remote Ls"

No other errors were reported during installation.

The shortcuts in the Start Menu are emtpy.

Thoughts?

kevinw
ActiveState Staff
Fri, 2007-04-13 15:32

There is a FAQ on installing ActiveTcl 8.4.14 on Vista that can be found here:

http://support.activestate.com/faq/what-version-of-activetcl-0

If I remember correctly, the Start menu entries don't work, but the other problems disappear if the install is run as Administrator (via the context menu).

Cheers,

kjw

BlairC | Fri, 2007-04-13 20:30

Thanks for the reply.

I did install as administator (via the context menu) but still encountered this problem. Additionally, I found that unless I move (or copy)the "...\demos\IWidgets" directory from it's installed location (C:\Tcl\demos\IWidgets) to "C:\Tcl\lib\Iwidgets4.0.2\demos", the catalog.tcl script fails. Upon completion of the installation, no "C:\Tcl\lib\Iwidgets4.0.2\demos" directory existed. This was different than what I experienced when installing in an XP environment.

Cheers

bac

Mercurial | Tue, 2007-05-29 15:14

Hi,

I had the same problem BlairC, no links in the Start Menu, everything else working fine (on a Desktop Computer with Vista at my job). But I found that if I chose to install only for current user (in ActiveTcl installation), everything worked fine on my laptop, including those Start Menu Links. So I think the problem is likely related with permissions.

It's not a big problem, but for me it was annoying, so my solution was to backup those links, re-install for all users and then copy the links to the right location (C:\ProgramData\Microsoft\Windows\Start Menu\Programs\ActiveState ActiveTcl 8.4.14.0) so that they appear in the Start Menu for all users...