install on Vista BASIC

Posted by ramigi on 2007-03-22 05:06

Hi!
Could someone please explain how to install perl on Vista Basic?
The message I get, is to call the computer's administrator (which happens to be...myself!!! help!).
RG

kevinw
ActiveState Staff
Thu, 2007-03-22 10:36

Hi,

What happens if you right-click the installer and select "Run as Administrator" or its equivalent?

That text also comes up when an error is encountered. If you ran into an error, can you please supply the text of the error?

Cheers,

kjw

ramigi | Thu, 2007-03-22 13:36

Hi,
Thanks for your reply, but unfortunatelly, this is what happens:

-When I try to right click on ActivePerl8.8.8.820-MSWin32-x64-274739 on the installer.bat file with "run as administrator", the 'Windows Command Processor' asks for permission, which I give and then, nothing happens.

-When I try to install ActivePerl8.8.8.809-MSWin32x86.msi: The possibility to "run as administrator" doesn't exist in the right click list, and when the installation process begins after a simple click (after accepting conditions etc), i get an error message saying "impossible to run as administrator".

Does any of this make any sense???

Thanks in advance,

RG

kevinw
ActiveState Staff
Thu, 2007-03-22 13:51

I noticed you used the x64 package for 5.8.8.820. Are you using a machine with a 64-bit OS installed or a 32-bit OS? If you're using a 32-bit OS you will need to try the x86 package.

In any case, is there anything in your Event Log about it? ActivePerl 5.8.8.820 has installed without issue on a 32-bit Vista Ultimate box here.

Cheers,

kjw

ramigi | Thu, 2007-03-22 14:45

There is no distiction between 32 and 64. It's the same pack (as it's name shows: ActivePerl8.8.8.820-MSWin32-x64-274739

kevinw
ActiveState Staff
Thu, 2007-03-22 14:19

I noticed above that you mention the installer.bat file. I recommend using the MSI package, as it has several benefits over the ZIP/AS package, such as an uninstaller. Try again with the MSI file and let me know what happens.

Cheers,

kjw

ramigi | Thu, 2007-03-22 15:00

The exact error message for msi is : "The system administrator has set policies to prevent this installation".

ramigi | Thu, 2007-03-22 14:51

Silly thought, may the problem be that Vista Basic doesn't have IIS (vs. premium and ultimate that have it) ? What to do in that case???

kevinw
ActiveState Staff
Thu, 2007-03-22 14:58

There is a difference between 32 and 64-bit packages. For example, here's the 5.8.8.820 package for 32-bit Windows (a.k.a. "x86"):

http://downloads.activestate.com/ActivePerl/Windows/5.8/ActivePerl-5.8.8...

The "MSWin32" part of the filename is no longer entirely accurate and is there for historical reasons, but shouldn't be -- here is a link to a bug suggesting it be removed:

http://bugs.activestate.com/show_bug.cgi?id=68433

Additionally, you mention ActivePerl 809 -- this is an obsolete version that has not been tested on Vista and is not expected to work there.

Cheers,

kjw

ramigi | Thu, 2007-03-22 15:10

I tried ActivePerl-5.8.8.820-MSWin32-x86-274739.msi and result is the same error message: 'the system administrator has set policies to prevent this installation'

kevinw
ActiveState Staff
Thu, 2007-03-22 15:11

You'll need to change your installation policies to allow the installation. Vista allows installations by default (at least it does on Ultimate -- I don't see why Basic would be any different), so it seems this is a problem with your system settings.

Cheers,

kjw

ramigi | Thu, 2007-03-22 15:14

any idea where i change your installation policies ? thanks!

kevinw
ActiveState Staff
Thu, 2007-03-22 15:27

These settings are likely to be under Control Panel | Administrative Tools | Local Security Policy. I am not familiar with User Account Control on Windows, so I can't provide much more advice than that.

Cheers,

kjw

ramigi | Fri, 2007-03-23 07:41

Here is the solution if you cannot install ActivePerl>msi on Windows Vista (Basic)and getting the error message "The administrator has set policies to prevent this installation":

1. Go to User Accounts
2. Click on "Turn User Account Control on or off"
3. Uncheck "User Account Control (UAC) to help protect your computer"
4. Follow instructions to restart your computer
5. install perl !

Thanks for everyone,

RG

kevinw
ActiveState Staff
Fri, 2007-03-23 11:10

I'm happy to hear you got it working! Thank you for posting the solution -- it will no doubt help others in the same situation. I appreciate it.

Cheers,

kjw