Install Crypt::SSLeay package

Posted by dtaylo75 on 2008-01-04 14:51
Forums: PPM | OS: Windows Server 2003

Crossposting here because I didn't see this forum when I initially posted, sorry...

Total newbie to perl here. I'm using a script provided by craigslist to facilitate bulk posting of listings to them.

Apparently their script requires a Crypt::SSLeay module installed.

I believe that the PPM utility in ActivePerl is what is used for managing modules, but I don't have the slightest idea how to tell this utility to install a new module. The best attempt I made was this:

C:\autotasks>ppm install Crypt::SSLeay
ppm install failed: Can't find any package that provides Crypt::SSLeay

Could somebody explain how the process of installing a module into PPM works under Windows. I see that I can download a .GZ file from CPAN, is this what I'm supposed to somehow "install" into PPM?

David
dtaylo75@bellsouth.net

grahams
ActiveState Staff
Fri, 2008-01-04 15:40

You got the syntax dead right. However, the ActiveState repository does not contain any modules that require crypt technology, since distribution of said technology in Canada requires a certificate from the Federal Government. The message from PPM that it can't find the module is normal.

There are other repositories that do provide this module, specifically Randy Kobes University of Winnipeg CPAN site.
To install Crypt-SSLeay from the Winnipeg repository using ppm, please do this from a dos prompt:

For ActivePerl 5.8

c:\> ppm install http://theoryx5.uwinnipeg.ca/ppms/Crypt-SSLeay.ppd

For 5.6.1

c:\> ppm install http://theoryx5.uwinnipeg.ca/ppmpackages/Crypt-SSLeay.ppd

thompsonson | Tue, 2008-02-26 23:26

I tried the following:

C:\Perl
$ ppm install http://theoryx5.uwinnipeg.ca/ppms/Crypt-SSLeay.ppd
ppm install failed: The PPD does not provide code to install for this platform

I have run "perl -v" and I am using:

This is perl, v5.10.0 built for MSWin32-x86-multi-thread

The release notes (http://aspn.activestate.com/ASPN/Downloads/ActivePerl/PPM/Repository) reference 5.6 and 5.8 but nothing for 5.10.

So i have 3 questions...

Is there a new package for 5.10?
Is there a way of making the 5.8 ppd work with 5.10?
Or should I downgrade my perl to 5.8? (I need to use HTTPS)

Thanks,
Matt

thompsonson | Tue, 2008-02-26 23:40

ignore the above it was available @ http://cpan.uwinnipeg.ca/PPMPackages/10xx/

ic3 | Thu, 2008-11-13 09:08

Hello,

Tried installing on Perl 5.6.1 on Windows XP, but this fails with a windows error unable to find 'C:Program'

Writing Y:\Data\perl\site\lib\auto\Crypt\SSLeay\.packlist
The system cannot find the file C:\Program.
Error installing package 'http://theoryx5.uwinnipeg.ca/ppmpackages/Crypt-SSLeay.ppd': PPM install script failed, status 256

It looks like this is truncating the file name C:\Program Files\... at the space and it also trows up a windows messagebox to the same effect. I've tried to trace the PPM, but I can't get it to log the trace file by using set trace 2 and set tracefile Y:\Perl\ppm.log.

Help!

grahams
ActiveState Staff
Wed, 2009-02-18 10:20

ActivePerl, even older versions like 5.6.1, will install to paths with spaces or special/utf-8 characters in the names, but many Perl scripts will not handle these pathnames. It leads to situations like this where modules will not install.
We use C:\Perl as the default install path to prevent some of these kinds of issues.