IIS, PerlIS.dll and perl scripts

Posted by sefs on 2007-05-08 07:25

Hi all,

I've installed ActiveState Perl 5.8.8 to work along side IIS and we are using perlis.dll as the parser. What is happening is that when ever we view a perl script we only see the html code printed out. I'm told that it is a result of result of perlis.dll sending default CGI HTTP headers and that we should turn them off, and that this is possibly done via a registry setting.

Does anyone know how to prevent perlis.dll from sending these default headers by disabling that feature in the registry?

Thanks very much.

verb0s | Thu, 2007-08-09 13:01

... i would also like to know the answer to this

sefs | Fri, 2007-08-10 04:53

Verb0s I had to downgrade to the version just under 5.8.8 to get rid of that problem. I've found no solution for it as yet.

Thanks.

nsharrok | Mon, 2008-03-31 15:16

Found a fix for you and me :)

http://www.4images.com/ntperl/perlis.htm

The problem is not one of incompatibility, it's one of understanding.

print "HTTP/1.0 200 OK\n";
print "Content-type: text/html\n\n"; <<< or whatever type you like

or

PerlIS DOESN'T automatically send the Content-type. It appears in your
document because the server did not get a status code, it assumes it
was 200 OK and the Content-type was text/html.

To disable this to use the redirect statement
Location: URL .

Use:
print "HTTP/1.0 302 Found\n";
print "Location: $URL\n\n";