how to install DBD:ODBC on Windows XP

Posted by jvo2007 on 2007-02-13 13:35
Forums: PPM | OS: Windows XP Pro

I don't do regular development in perl, but I use it a lot for basic file manipulation. That's the easy way to say that my perl skills are weak at best. I'm at a point in an application where I need perl to communicate with an SQL Server database on a Windows XP machine. I have loaded activestate perl 5.8.8.820 on my machine. It does not appear to have DBD:ODBC installed. What are the steps necessary to get DBD:ODBC on my machine so that I can use the perl DBI to talk to a local SQL Server database?

Thanks in advance for any help,

kevinw
ActiveState Staff
Wed, 2007-02-14 14:53

Hi,

The following should work from a command prompt:

ppm install DBD-ODBC

You may also have to install the DBI package if the above module doesn't specify it as a dependency:

ppm install DBI

The PPM tool also has a GUI that can be started from the Windows Start Menu or by typing "ppm" or "ppm gui" at a command prompt.

Cheers,

kjw

lnguyen | Tue, 2007-02-20 12:03

Help. While running DBD-ADO, I get an error: "Package 'Win32-OLE'not found. Please search for it first.". Please tell me how to fix this error.

I am running on Windows XP. And just installed Perl (ActiverPerl 5.8.7.815; ppm version 3.3.)

kevinw
ActiveState Staff
Wed, 2007-02-28 15:06

That error is due to a dependency problem with the DBD-ADO package. That package has been fixed and is being rebuilt -- expect it to be live within an hour or so of this message. You will be able to install it via PPM as normal after that.

Cheers,

kjw

algaspar | Thu, 2007-05-17 11:14

I have a perl script that uses dbi:ADO to connect to a database and run a query. I moved to a new server running Server 2003 and installed the latest version of Perl (5.8.8 build 820). My script gave me an error that it couldn't locate DBD/ADO.pm; so I went looking for it.

When I ran ppm, I didn't see DBD-ADO; so I tried to install DBD-ADO, and it can't find it in the repository. An older installation on my workstation finds it, but when I try to go to that repository with the ppm that came with build 820, it gives me an error: "PPM3 SOAP repositories are not supported."

What do I need to do to get this installed? Is there a different repository that works with ppm3? I was going to try CPAN, but that made an even bigger mess. I appreciate any help.

Thanks--

Al Gaspar

algaspar | Thu, 2007-05-24 10:49

I see now that it is ppm4 that doesn't understand the ppm3 SOAP repositories. In any case, I couldn't get around this. I uninstalled 820 and installed 813. The script couldn't find DBI.pm and then it couldn't find DBD::ADO. I used ppm to download those modules and all was well. I guess I need to wait before I go to 820.

--Al

rvino | Wed, 2007-10-10 04:13

Try this one

install dependency plrpc and DBD::ODBC was force reinstalled using the command “ppm install DBD::ODBC –force”

freetomove | Mon, 2008-01-28 23:19

I am using ActivePerl-5.8.8.822.
I am trying to connect to SQL database.
I tried to use the command "ppm install DBD-ODBC" for installing DBD-ODBC Driver -- but it is showing the following error :

Downloading ActiceState Package Repository packlist...failed 500 can't connect to ppm4.activestate.com:80(connect: unknown error)
ppm install failed : Can't find any package that provide DBD-ODBC

What should i do now to connect to SQL...please help me...

MarcZ | Tue, 2008-01-29 14:33

As an alternate method for installing packages, you can download zip files for the packages that you need from http://ppm.activestate.com/PPMPackages/zips/.
To use these files:

1. Unzip the package to a temporary directory.
2. Install the package by specifying the ppd file directly:
ppm install c:\tmp\module-name.ppd

to get the zip files for 5.8.8 build 822 point your web browser to

http://ppm4.activestate.com/PPMPackages/zips/

download the DBD-ODBC from the Windows directory.

arlie | Thu, 2008-03-27 18:59

Did this on Windows XP:

ppm install DBD-ODBC.ppd

got this:

ppm install failed: Can't find any package that provide DBI version 1.21 for DB-ODBC

~~~

I'm a perl newbie. I'll be glad if someone could help on this.

Regards,

Arlie

grahams
ActiveState Staff
Tue, 2008-04-22 15:53

There have been some problems on the PPM servers in the past months which meant that at times certain modules were unavailable when the repository indicated they ware available. Things should be back to normal now.