Encode on 5.6.1

Posted by davidmaxwaterman on 2007-04-16 18:33
Forums: PPM | OS: Windows XP Pro

I'm new to MS Windows and using perl on it...I'm using version 5.6.1 as required by the SDK I'm using.

I find myself needing the Encode perl module :

>perl test.pl
Can't locate Encode.pm in @INC (@INC contains: C:/Perl/lib C:/Perl/site/lib .) a
t test.pl line 17.
BEGIN failed--compilation aborted at test.pl line 17.

so I figure I need to install it, but am having trouble.

My first attempts resulted in

ppm> install Encode
====================
Install 'Encode' version 1.99 in ActivePerl 5.6.1.638.
====================
====================
Install 'Encode' version 1.99 in ActivePerl 5.6.1.638.
====================
Error: error downloading 'http://ppm.activestate.com/PPMPackages/5.6/MS-
Win32-x86-multi-thread/Encode-1.99.tar.gz': 404 Not Found

I then tried to add some other respositories, but and it now does this :

ppm> install Encode
====================
Install 'Encode' version 1.99 in ActivePerl 5.6.1.638.
====================
====================
Install 'Encode' version 1.99 in ActivePerl 5.6.1.638.
====================
====================
Install 'Encode' version 1.99 in ActivePerl 5.6.1.638.
====================
Error: Package 'Encode' not found on server. Please 'search' for it

Can someone point me in the right direction?

Thanks.

Max.

gunnarsutter | Fri, 2007-09-21 06:04

There seems to be little or no activity on this board but I'll give it a try and hopefully bump this thread.

I have exactly the same problem.

Looking at the availible packages it says that there is something wrong with this one. Is there any chance to download an old stable version compatible with 5.6.1.

Best regards
G Sutter