configure: WARNING: Can't find Tcl configuration definitions

Posted by Jfmxl on 2007-07-31 02:18

downloaded WordNet which requires Tcl/Tk to build
configure couldn't find it on my machine
I couldn't find an ubuntu package either, so I downloaded AS
but the result is the same
configure: WARNING: Can't find Tcl configuration definitions
how shall I proceed?

Thanks.

Jfmxl | Tue, 2007-07-31 02:29

./configure --with-tclconfig=/usr/local/ActiveTcl-8.4/lib/ --with-tkconfig=/usr/local/ActiveTcl-8.4/lib/

did the trick

mounika46779@gm... | Tue, 2018-06-26 21:07

I have executed that one it's like tclconfig.sh doesn't exist.

[mona@localhost expect5.45.3]$ ./configure --with-tclconfig=/usr/local/ActiveTcl-8.4/lib/ --with-tkconfig=/usr/local/ActiveTcl-8.4/lib/
checking for correct TEA configuration... ok (TEA 3.9)
configure: configuring expect 5.45.3
checking for Tcl configuration... configure: error: /usr/local/ActiveTcl-8.4/lib/ directory doesn't contain tclConfig.sh

grahams
ActiveState Staff
Thu, 2018-07-12 14:43

The post is from 2007, and ActiveTcl 8.4 was common then. 8.4 has been end-of-life for five years, and it's rather likely that you have a different version on a different path.