Can't get Win32 module to install

Posted by emwarren on 2008-06-09 15:04
Forums: PPM | OS: Windows XP Pro

When I use the PPM gui to try to install the Win32 package I get this error:

"Installing package ...
Downloading Win32-x86-multi-thread-5.8/Win32-0.34 ... failed 500 Cannot write to 'C:\DOCUME~1\kat\LOCALS~1\Temp\ppm-4ihCGB/Win32-x86-multi-thread-5.8/Win32-0.34.tgz': No such file or directory
Installing package failed

ERROR: 500 Cannot write to 'C:\DOCUME~1\kat\LOCALS~1\Temp\ppm-4ihCGB/Win32-x86-multi-thread-5.8/Win32-0.34.tgz': No such file or directory"

I can install any other package on this machine as the same user.

I notice while ever other package has a version such as "1.0" or "0.34", this package has a version of:

"x86-multi-thread-5.8/Win32-0.34"

Any thoughts?

samir | Thu, 2008-08-21 13:40

Hi - I saw a post from June 2008 having the same issues as this user did. Basically i get an Error 500 saying it Cannot write to directory...

Did somebody solve this?

pbrodd | Fri, 2008-09-12 10:26

I am having exactly the same problem. Is there any workaround?

Thanks.

samir | Fri, 2008-09-12 10:31

...actually, I never solved this. I do know there is a difference on the ActiveState Perl Builds of 822 vs. 817. Things in Win32 flaked out on 822. But they worked on 817. So after installing 817, I never had a need for the ppm stuff to be solved.

grahams
ActiveState Staff
Fri, 2008-09-19 13:41

The original error was due to a build problem on our old PPM architecture. The module failed to build and was deleted, but the index indicated it was still present.
Since then the build architecture has been completely ripped out and rebuilt, Win32 is now at 0.38, and 5.8.8.824 has been released. 822 will properly update to the new version with PPM, or you can install 824 (recommended).